Home > Failed To > Gem Install Mysql2 Windows

Gem Install Mysql2 Windows

Contents

You may need configuration options. As far as I can tell, this is related to b97ec2a C:\ruby-1.9.3-p547\bin> gem install json Temporarily enhancing PATH to include DevKit... How could Talia Winters help the rogue telepaths against Bester? Make an interweaving quine Which process is `/proc/self/` for? weblink

Fixes #977.">Don't use relative paths on Windows. Yükleniyor... Why call it a "major" revision if the suggested changes are seemingly minor? make sure you are linking to the directory properly (where the mysql connector you downloaded is (the include and lib dir)) also copy libmysql.dll to your ruby bin directory.

Gem Install Mysql2 Windows

Provided configuration options: --with-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=/Users/eric/.rvm/rubies/ruby-2.0.0-p195/bin/ruby --with-mysql-config --without-mysql-config --with-mysql-dir --without-mysql-dir --with-mysql-include --without-mysql-include=${mysql-dir}/include --with-mysql-lib --without-mysql-lib=${mysql-dir}/ --with-mysqlclientlib --without-mysqlclientlib --with-mlib --without-mlib --with-mysqlclientlib --without-mysqlclientlib --with-zlib --without-zlib --with-mysqlclientlib --without-mysqlclientlib It helped in installing mongoid for me. (bson gem was stopping me from moving forward) mrthan commented Jan 8, 2015 I'm still getting this issue in 2.4.5 - reverting to 2.3.0 Check the mkmf.log file for more details. make failed, exit code 2 Gem files will remain installed in C:/Ruby193/lib/ruby/gems/1.9.1/gems/json-1.8. 1 for inspection.

I should mention this is my first real foray into RoR, so it's quite possible I'm the problem... share|improve this answer edited Jun 26 '14 at 10:43 byJeevan 1,55311339 answered Jun 26 '14 at 10:23 hira umair 111 THANK YOU I've been looking everywhere, but nothing was A copy/paste part from the error message: ERROR: Error installing mysql2: ERROR: Failed to build gem native extension. Error Installing Rmagick: Error: Failed To Build Gem Native Extension. There is a resolution for it, but it's not in the latest version of Ruby from rubyinstaller.org.

What's the purpose of the same page tool? For some reason just specifying the mysql-dir when you install the gem doesn't pick up with other sub directories so you need to set the parameters manually. How can I easily double any size number in my head? NextKh IT 375 görüntüleme 5:47 Ruby on Rails Tutorial | Build a Book Review App - Part 1 - Süre: 39:11.

that's why everyone prefers linux. Extconf.rb Failed Windows Results logged to C:/Ruby200/lib/ruby/gems/2.0.0/gems/mysql2-0.3.11/ext/mysql2/g em_make.out I guess I missed something with mingw. DevKit is installed. What is the impact on the world politics if teleportation is possible?

E: Unable To Locate Package Libmysql-ruby

no checking for mysql_query() in -lmysqlclient... Did Malcolm X say that Islam has shown him that a blanket indictment of all white people is wrong? Gem Install Mysql2 Windows I figured out what went wrong with it. Failed To Build Gem Native Extension. Mysql2 crmckenzie commented Feb 22, 2015 👍 to @gparvind 's question about when will this be fixed.

Geoff Parsons 11,635 Points Geoff Parsons Geoff Parsons 11,635 Points 2y ago Looks like it can be a bit more tricky than just a gem install to get the mysql2 gem have a peek at these guys Resolving dependencies... ... ... ... egad1868 commented Dec 28, 2014 Worked for me! Fetching gem metadata from https://rubygems.org/.. Gem Install Mysql2 Fails

For some reason, I do have two directories of MySQL (one in Program Files, and one in Program Files x86), and I'm not sure why. C:/Ruby193/bin/ruby.exe -r ./siteconf20140809-24288-wfgqsd.rb extconf.rb creating Makefile make clean Makefile:165: *** target pattern contains no `%'. Run CMD and go to dir where is Development Kit extracted Run ruby dk.rb init Run ruby dk.rb install Run gem install mysql2 -- '--with-mysql-lib="c:\Program Files\MySQL\MySQL Server 5.7\lib" --with-mysql-include="c:\Program Files\MySQL\MySQL Server check over here luislavena referenced this issue in oneclick/rubyinstaller Oct 22, 2014 Closed Error installing mysql gem #191 markdav commented Nov 22, 2014 Thanks folks, downgrading worked for me too.

Why didn't the Roman maniple make a comeback in the Renaissance? Error: Failed To Build Gem Native Extension. Windows Oturum aç 4 0 Bu videoyu beğenmediniz mi? Contributor djberg96 commented May 30, 2015 Experiments show that just changing this line back to the previous code works: tmp_dest = get_relative_path(Dir.mktmpdir(".gem.", ".")) # Doesn't work tmp_dest = Dir.mktmpdir(".gem.", ".") #

thanks.

Fixes #977http://chatflow.net/failed-to/failed-to-install-adam.html Where may I find explanation?

make failed, exit code 2 Gem files will remain installed in C:/Ruby193/lib/ruby/gems/1.9.1/gems/json-1.8.1 for inspection. Because I wasn't sure whether changing these would break the installation, once I realised why the problem was arising I just created a symlink from the command line ( something that Mani Muridi 305 görüntüleme 2:45 Installing Ruby on Rails 4, Ruby 2.0 and the MySQL2 gem on Windows 7 - Süre: 23:09. downgrading works but any idea when it's planned to be fixed?

Stop. Because I've got two versions of ruby installed, and each requires a different devkit (one for 2x and one for 1x), I had to do the setup for devkit twice: cd A bit, a nibble or bite? C:\beef>gem install debugger Fetching: debugger-linecache-1.2.0.gem (100%) Successfully installed debugger-linecache-1.2.0 Fetching: debugger-ruby_core_source-1.3.8.gem (100%) Successfully installed debugger-ruby_core_source-1.3.8 Fetching: columnize-0.9.0.gem (100%) Successfully installed columnize-0.9.0 Fetching: debugger-1.6.8.gem (100%) Temporarily enhancing PATH to include DevKit...

That way your development machine will very closely match your production environment. Mine got installed after I ran following command : gem install mysql2 --platform=ruby -- '--with-mysql-lib= "C:\mysql-connector\lib" --with-mysql-include="C:\mysql-connector\include" --wit h-mysql-dir="C:\mysql-connector"' Same command was not working when my antivirus was enabled, as it I am getting the same error. This could take a while...

To tell Rails to use mysql2, you have to remove sqlite3 from gemfile and add the mysql2 gem in its place. luislavena referenced this issue in oneclick/rubyinstaller Dec 2, 2014 Closed RubyGems.org patched for Poodle SSLv3 (CVE-2014-3566) breaks Windows gem commands #241 psudarshan commented Dec 16, 2014 Thanks a lot!! Our mission is to bring affordable, technology education to people everywhere, in order to help them achieve their dreams and change the world. I have been searching for this solution for long time, was not able to use debugger with rubymine.

It's working now!!! Thanks again! This could take a while... How do I create armor for a physically weak species?

Make sure that gem install json -v '1.8.1' succeeds before bundling. This was referenced Jul 16, 2015 Merged Migrate to sdkdocs_template JetBrains/intellij-sdk-docs#6 Closed Add support for Windows brigade/overcommit#185 tolukareem commented Jul 24, 2015 Downgrading totally worked! ritcheyer commented Jun 20, 2013 Update - In starting a question on SO, this article popped up which I hadn't found before. I am under windows XP with Ruby 2.0.0 and DevKit installed as well.